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KBAlertz.com: Event ID 21213 or event ID 21216 occurs and you cannot connect to the OnePoint database in Microsoft Operations Manager 2005

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Microsoft Knowledge Base Article

This article contents is Microsoft Copyrighted material.
©2005-©2007 Microsoft Corporation. All rights reserved. Terms of Use | Trademarks

Event ID 21213 or event ID 21216 occurs and you cannot connect to the OnePoint database in Microsoft Operations Manager 2005

Article ID:917665
Last Review:October 27, 2006
Revision:1.1

SYMPTOMS

When you use the OnePoint database on a computer that is running Microsoft Operations Manager (MOM) 2005 or MOM 2000, the size of the OnePoint database increases quickly. Therefore, some MOM rule scripts may run in an infinite loop.

When this problem occurs, one or more of the following event messages may be logged in the Application log.
Event ID numberBasic description
21213Indicates a Heartbeat update failure from one or more MOM agents
21216Indicates that the MOM server was not able to process incoming configuration information
Additionally, the following event messages may be logged in the Application log.
Event ID numberBasic description
21418 (MOM 2000 only)Indicates a script running in an infinite loop
21421 (MOM 2005 only)Indicates a script running in an infinite loop
25101Indicates a failure to insert data into the database
25102indicates an unrecoverable database error
21268Indicates that the incoming queue is blocked and is not able to accept data.
21269Indicates that the queue has been unblocked and can accept data
25402 Indicates that the WMI provider could not register a query
Note On a computer that is running MOM 2005, you can also view the event messages in the previous tables in the event views pane of the Operator console.

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CAUSE

This problem occurs because the transaction log runs out of space. This behavior may occur if the OnePoint database Recovery Model is set to Full and if a backup has not been run for some time. In this situation, you can only truncate the transaction logs by backing up the transaction log.

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RESOLUTION

To resolve this problem, follow these steps:
1.Set the OnePoint database recovery model to Simple. To do this, follow these steps:
a. Open SQL Server Enterprise Manager.
b. Under Microsoft SQL Server, expand SQL Server Group.
c. Click the name of the server computer that is hosting the OnePoint database, and then expand Databases.
d. Right-click the OnePoint database, and then click Properties
e. In the OnePoint Properties dialog box, click the Options tab.
f. In the Recovery section, select Simple from the Model menu, and then click OK.
2. Truncate the transaction log by backing up the OnePoint database.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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APPLIES TO
•Microsoft Operations Manager (MOM) 2005
•Microsoft Operations Manager 2000 Service Pack 1

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Keywords: 
kbexpertiseinter kbtshoot kbfix kbprb KB917665

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